The Subaru SVX World Network   SVX Network Forums
Live Chat!
SVX or Subaru Links
Old Lockers
Photo Post
How-To Documents
Message Archive
SVX Shop Search
IRC users:
SVXBot

Go Back   The Subaru SVX World Network > SVX Main Forums > Technical Q & A

Reply
 
Thread Tools Display Modes
  #1  
Old 05-03-2022, 02:42 PM
elemgee elemgee is offline
Registered User
 
Join Date: Jul 2008
Location: United States
Posts: 169
Odometer and Trip Odometer Not Working

My odometer and trip odometer on my 97 stopped working. So when I drive, the miles on the odometer don't change, and when I press the trip odometer button, it doesnt do anything.

Also, I'm not sure this is related to the above, but my "passenger door open" pictogram thingy stays on when the door is clearly closed. Its minor and I don't really care about it but thought it might be related to the above.

Is this something I can fix myself (I've removed the gauge cluster before) or should I have it sent out to someone to fix who does this type of repair?

One other question: if I buy a used replacement gauge cluster, can the mileage be adjusted to reflect the actual mileage of the car its going into, and if so, how would I do that?

Thanks.

Larry

Last edited by elemgee; 05-04-2022 at 09:50 PM. Reason: Want to add another question
Reply With Quote
  #2  
Old 07-14-2022, 08:26 PM
elemgee elemgee is offline
Registered User
 
Join Date: Jul 2008
Location: United States
Posts: 169
Re: Odometer and Trip Odometer Not Working

An update to my initial odometer / trip meter not working problem:

I read a number of posts in other forums about issues similar to mine. They indicated that if the speedometer and tachometer were working (they were) the problem most like rests within the gauge cluster itself (and not, for example, with the vehicle speed sensor).

So I sent out the gauge cluster to a company that specializes in their repair (Pohl's). They sent the repaired gauge cluster back but the odometer and trip meter still dont work. All other gauges work fine. I should mention I tried another used gauge cluster and the odometer and trip meter on that one also didn't work. So the problem clearly does not seem to be within my gauge cluster.

Any thoughts as to what the problem might be would be very much appreciated.

Larry
Reply With Quote
  #3  
Old 07-15-2022, 11:52 PM
svxnavyvet svxnavyvet is offline
Registered User
 
Join Date: May 2017
Location: Edwall washington
Posts: 143
Registered SVX
Re: Odometer and Trip Odometer Not Working

Check the connection it plugs into look at the foil see if it is corroded or cracked
Reply With Quote
  #4  
Old 07-18-2022, 05:41 PM
elemgee elemgee is offline
Registered User
 
Join Date: Jul 2008
Location: United States
Posts: 169
Re: Odometer and Trip Odometer Not Working

That was a good suggestion, so I removed the cluster and checked, and the connections and they all look good.

I was wondering if the problem could be electrical and so was able to find a gauge cluster wiring diagram on the internet. I was hoping it would show some electrical connections for the odometer and trip meter (maybe a fuse, or some wiring connections) but there aren't any, so I'm sort of out of ideas.
Reply With Quote
  #5  
Old 07-18-2022, 09:55 PM
irox irox is offline
Registered User
 
Join Date: Jun 2016
Location: CA
Posts: 303
Re: Odometer and Trip Odometer Not Working

Sorry to hear you are having issues with you're Odometer.

To trace the wiring, you could try starting at the Vehicle Speed Sensor, then trace it back to the instrument cluster. I'm not sure how different the '97 will be vs '92, but the 1992 FSM Body Electrical System chapter, section 13 covers the Vehicle Speed Sensor. Seems the Speed Sensor signal goes to connector B83 terminal 7 on the Cruise Control Unit, from connect B9 on the Vehicle Speed Sensor.

The Body Electrical System chapter also has a trouble shooting action.

Do you have any error codes? You've go the fancy OBD2 system, so things will be different than the '92 OBD1, but you might be able to get more interesting things out of ODB2 that could help with debugging this.

Part of me worries that if you're speedometer is working fine, then the problem may be inside of the instrument cluster. Does Cruise Control work for you?

Good luck!
Reply With Quote
  #6  
Old 07-31-2022, 02:21 PM
elemgee elemgee is offline
Registered User
 
Join Date: Jul 2008
Location: United States
Posts: 169
Re: Odometer and Trip Odometer Not Working

Thanks for your help. I dont have any CEL codes. As I mentioned above, I had the internal workings checked / fixed and so supposedly the problem is not with the odometer itself.

I'm going to put the dash back together, then take it out for a spin and try the cruise control. If the cruise control doesnt work then I'll replace the speed sensor; if it does work, I'll be calling it a day.
Reply With Quote
  #7  
Old 07-31-2022, 03:29 PM
Blacky Blacky is offline
51 Club
 
Join Date: Aug 2008
Location: LSM, Quebec
Posts: 2,455
Registered SVX
Re: Odometer and Trip Odometer Not Working

The sensor is about $200 but at least it's still available unlike a lot of other SVX parts.
__________________
1997 Bordeaux Pearl, 2010 Mercedes Benz GLK350, 2018 BMW 640i GT Xdrive, 2012 Moto Guzzi Norge GT 8V,
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
2001-2015 SVX World Network
(208)-906-1122