The Subaru SVX World Network

The Subaru SVX World Network (https://www.subaru-svx.net/forum/index.php)
-   Technical Q & A (https://www.subaru-svx.net/forum/forumdisplay.php?f=5)
-   -   Stereo Question (https://www.subaru-svx.net/forum/showthread.php?t=65201)

SVX_MY_BABY 06-04-2021 08:48 AM

Stereo Question
 
Here's an odd one.

Both door speakers on my SVX have stopped working. The tweeters and rear deck speakers are fine. The fader control works. (To the extent that I can confirm that the tweeters are functioning.)

Could it just be a loose wire inside one of the doors?

Black88GTA 06-04-2021 07:13 PM

Re: Stereo Question
 
Quote:

Originally Posted by SVX_MY_BABY (Post 753173)
Here's an odd one.

Both door speakers on my SVX have stopped working. The tweeters and rear deck speakers are fine. The fader control works. (To the extent that I can confirm that the tweeters are functioning.)

Could it just be a loose wire inside one of the doors?

OEM head unit, or aftermarket? Do you have another head unit laying around you could use to test with? If nothing else, you could check wiring continuity with a 9v battery:
https://www.youtube.com/watch?v=xIMHGkxw72o

When I first started fixing up my 92, it had the OEM HU in it, and some obvious stereo work done in the past (aftermarket speakers, stray wiring, etc). Sound only came (weakly) out of one rear channel. I figured the whole thing was a write off and would have to redo it all, but then dropped in a new HU and everything worked again. In my case, seems the internal amplifier in the OEM head unit was shot. Good luck.

SVX_MY_BABY 06-05-2021 08:10 AM

Re: Stereo Question
 
Quote:

Originally Posted by Black88GTA (Post 753177)
OEM head unit, or aftermarket? Do you have another head unit laying around

OE unit. I do have another OE unit in my parts stack.


All times are GMT -6. The time now is 05:51 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
2001-2015 SVX World Network
(208)-906-1122