The Subaru SVX World Network   SVX Network Forums
Live Chat!
SVX or Subaru Links
Old Lockers
Photo Post
How-To Documents
Message Archive
SVX Shop Search
IRC users:
SVXBot

Go Back   The Subaru SVX World Network > SVX Main Forums > Technical Q & A

Reply
 
Thread Tools Display Modes
  #1  
Old 01-21-2019, 02:57 AM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,361
OEM amplifier question

OK so my OEM unit has front right speaker issue - very little volume when turned to max (all other speakers are ok) - the fronts were changed approx 6 months ago.
When the unit is turned off I hear a pop from that speaker, almost like it is biased DC (hence the AC/music cannot get through).

Have checked the speaker with output from amplifier that I have in the garage...no issues.

Is the amplifier part of the CD unit or the tuner unit ?.

Not looking forward to taking this out of the dash !!
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted. Added Gear Firm-Up unit (that I sell), Power TCU ROM & Power switch.
Reply With Quote
  #2  
Old 01-21-2019, 05:33 AM
Tireiron Tireiron is offline
Registered User
 
Join Date: Apr 2012
Location: Methuen, MA
Posts: 249
Re: OEM amplifier question

It's part of the headunit iteself. The CD unit is only a CD. And there is no external amplifier. If the speaker works correctly when connected to a different souce, and the wiring connection to the speaker is good in the door (test the wiring from the speaker to the headunit to be sure there isn't an issue with it, could have become damaged somewhere), chances are there is an issue in the headunit.
Reply With Quote
  #3  
Old 01-21-2019, 01:02 PM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,361
Re: OEM amplifier question

Does anyone in this group have the service manual for the panasonic tuner/amplifier - if I cannot fix the original OEM I will look for another OEM that works (but it may be from a JDM which means looking at both units apart to see if I can figure out how to increase the radio frequencies from Japan to New Zealand frequencies).
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted. Added Gear Firm-Up unit (that I sell), Power TCU ROM & Power switch.
Reply With Quote
  #4  
Old 01-21-2019, 03:52 PM
Trevor's Avatar
Trevor Trevor is offline
Registered User
 
Join Date: Feb 2002
Location: Auckland, New Zealand
Posts: 5,154
Registered SVX
Re: OEM amplifier question

For a couple of years after selling my original Companies, I established, owned and operated Auto Hi Fi Ltd from my premises, 63 Barrys Point Road Takapuna (Now a motor cycle dealership) and carried out to all the component servicing so have in-depth experience concerning your problem.

I gather that the unit probably incorporates a front rear speaker fader control and if so this could involve your problem. If you phone me I can assist you. I will not need the service manual.

Regards, Trevor.
__________________
Trevor, New Zealand.

As a child, on cold mornings I gladly stood in cowpats to warm my bare feet, but I detest bull$hit!
Reply With Quote
  #5  
Old 01-22-2019, 03:46 AM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,361
Re: OEM amplifier question

Trevor - small world, I worked at 65 Barrys Point Road over Xmas school holidays for 3 years in the late 1970s, the guy who owned the shop was into motor car racing.

Will leave the stereo for the moment, as I have just completed the "POWER MODE" addition - only to find that my NZ New may not actually have the pin wired from within the module ???? NO power light comes on in any gear when the A4 pin is grounded.

I have 2 other modules from JDM models, so will swap the module with one of those to see if I can get some closure on this addition.
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted. Added Gear Firm-Up unit (that I sell), Power TCU ROM & Power switch.

Last edited by SURTEESS; 01-22-2019 at 03:51 AM.
Reply With Quote
  #6  
Old 01-22-2019, 02:42 PM
Trevor's Avatar
Trevor Trevor is offline
Registered User
 
Join Date: Feb 2002
Location: Auckland, New Zealand
Posts: 5,154
Registered SVX
Re: OEM amplifier question

Small world for sure.

I purchased 63 Barrys Point road 28/02/2086 from Les Sanders Ltd, plumbing contractors. The building had previously been let to a boat building outfit, I think was smuggler Boats who built fibre glass trailer boats and who took their business to Australia when sales tax became applied to boats. I occupied the property as Boat Town Ltd before establishing auto Hi Fi Ltd.

Make sure there are no short circuits within the speaker leads when you are experimenting, as otherwise the output stage transistors or IC's are in grave danger. LOL
__________________
Trevor, New Zealand.

As a child, on cold mornings I gladly stood in cowpats to warm my bare feet, but I detest bull$hit!
Reply With Quote
  #7  
Old 01-22-2019, 05:50 PM
oab_au oab_au is online now
Registered User
Subaru Gold Contributor
 
Join Date: Mar 2001
Location: Coffs Harb, Australia.
Posts: 4,971
Significant Technical Input Registered SVX
Re: OEM amplifier question

Quote:
Originally Posted by SURTEESS View Post

Will leave the stereo for the moment, as I have just completed the "POWER MODE" addition - only to find that my NZ New may not actually have the pin wired from within the module ???? NO power light comes on in any gear when the A4 pin is grounded.

I have 2 other modules from JDM models, so will swap the module with one of those to see if I can get some closure on this addition.
On your car grounding pin 4 turns the Economy Mode on, that is fitted to our right hand drive models, but the NZ and Australian cars did not have a switch fitted to turn it on.

Fitting a JDM TCU will not work in our models as the front speed sensors are different.

Some time ago I sent you a ROM that has the Economy map replaced with the JDM power map, if you solder the socket in, plug the ROM in and remove the original ROM, the JDM Power Mode shift maps will be turned on, grounding pin 4 then, will turn it off.

Harvey.
__________________
One Arm Bloke.
Tell it like it is!

95 Lsi. Bordeaux Pearl, Aust. RHD.149,000Kls Subaru BBS wheels.
97 Liberty GX Auto sedan. 320,000Kls.
04 Liberty 30R Auto Premium. 92.000kls.
Reply With Quote
  #8  
Old 01-22-2019, 06:49 PM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,361
Re: OEM amplifier question

Harvey, yes I remember that addition that you sent me - now just got to find which box it is located in (from about 30 boxes - each about 300mm x 300mm x 300mm).


I wanted to ground the A4 pin in order to turn on the "POWER" indicator ....... will this work with the ROM you sent me ?.

Attached is a picture of the NZ (left) with JDM (right)

Harvey, do I place your ROM into the empty space and then remove the IC above it ?.
Attached Images
File Type: jpg DSCN4861.JPG (424.3 KB, 11 views)
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted. Added Gear Firm-Up unit (that I sell), Power TCU ROM & Power switch.

Last edited by SURTEESS; 01-22-2019 at 07:34 PM.
Reply With Quote
  #9  
Old 01-22-2019, 08:13 PM
oab_au oab_au is online now
Registered User
Subaru Gold Contributor
 
Join Date: Mar 2001
Location: Coffs Harb, Australia.
Posts: 4,971
Significant Technical Input Registered SVX
Re: OEM amplifier question

Quote:
Originally Posted by SURTEESS View Post
Harvey, yes I remember that addition that you sent me - now just got to find which box it is located in (from about 30 boxes - each about 300mm x 300mm x 300mm).


I wanted to ground the A4 pin in order to turn on the "POWER" indicator ....... will this work with the ROM you sent me ?.

Attached is a picture of the NZ (left) with JDM (right)

Harvey, do I place your ROM into the empty space and then remove the IC above it ?.
The way Phil set it up, it is off when grounded, on when open, so you can work some thing out with the JDM switch.
Yes it is an easy fit, suck the solder out of the board, solder the socket in, plug the ROM in, No, 1 pin top left as your pict shows, remove or disable the original ROM.

This removes the Economy map replacing them with the full set of POWER shift maps that the JDM cars have, makes it a different car to drive.
__________________
One Arm Bloke.
Tell it like it is!

95 Lsi. Bordeaux Pearl, Aust. RHD.149,000Kls Subaru BBS wheels.
97 Liberty GX Auto sedan. 320,000Kls.
04 Liberty 30R Auto Premium. 92.000kls.
Reply With Quote
  #10  
Old 01-22-2019, 09:16 PM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,361
Re: OEM amplifier question

cool - thanks, will get the desoldering / soldering stuff out when I find the ROM.

I take it the OEM ROM is at top right - if so all I need to do is lift the VCC pin and leave the OEM ROM in place?.

please confirm...thanks
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted. Added Gear Firm-Up unit (that I sell), Power TCU ROM & Power switch.
Reply With Quote
  #11  
Old 01-22-2019, 11:33 PM
oab_au oab_au is online now
Registered User
Subaru Gold Contributor
 
Join Date: Mar 2001
Location: Coffs Harb, Australia.
Posts: 4,971
Significant Technical Input Registered SVX
Re: OEM amplifier question

There is a selection resistor on the board somewhere you can cut, but just lift the Vcc pin to disable it.
__________________
One Arm Bloke.
Tell it like it is!

95 Lsi. Bordeaux Pearl, Aust. RHD.149,000Kls Subaru BBS wheels.
97 Liberty GX Auto sedan. 320,000Kls.
04 Liberty 30R Auto Premium. 92.000kls.
Reply With Quote
  #12  
Old 01-23-2019, 01:22 PM
Trevor's Avatar
Trevor Trevor is offline
Registered User
 
Join Date: Feb 2002
Location: Auckland, New Zealand
Posts: 5,154
Registered SVX
Re: OEM amplifier question

Rather than damage through-the-board components, it is better to neatly cut the appropriate board track. In the event that things do not work out, the break can easily be restored by soldering across the cut. This is an approved technique used when necessary in order to isolate components during trouble shooting.
__________________
Trevor, New Zealand.

As a child, on cold mornings I gladly stood in cowpats to warm my bare feet, but I detest bull$hit!
Reply With Quote
  #13  
Old 01-23-2019, 01:32 PM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,361
Re: OEM amplifier question

Found the linking resistor - http://www.alcyone.org.uk/ssm/tcumod.html


Move R432 to location R431

will do the mod and install today.

Many thanks for all your help.
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted. Added Gear Firm-Up unit (that I sell), Power TCU ROM & Power switch.
Reply With Quote
  #14  
Old 01-23-2019, 05:54 PM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,361
Re: OEM amplifier question

OK mod completed, now for the install - tomorrow, as it is to hot in the garage after midday (28 deg C).

The only hard part about sucking out solder in the empty ROM DIP-28 place is that pin 14 is joined to a large copper plane, this causes the heat to dissapate and hence solder not to reflow easily, ended up placing a bigger tip on the soldering iron to get more heat for copper braid - so that solder could flow easrier up the braid.

Third digit on the OEM ROM is the year the car was made - Dec 94 for mine.

Will let you all know how the install goes in another posting....

Photos attached.....
Attached Images
File Type: jpg DSCN4871.JPG (813.8 KB, 12 views)
File Type: jpg DSCN4872.JPG (438.2 KB, 11 views)
File Type: jpg DSCN4873.JPG (440.2 KB, 11 views)
File Type: jpg DSCN4874.JPG (830.6 KB, 9 views)
File Type: jpg DSCN4875.JPG (756.6 KB, 11 views)
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted. Added Gear Firm-Up unit (that I sell), Power TCU ROM & Power switch.
Reply With Quote
  #15  
Old 01-23-2019, 06:19 PM
oab_au oab_au is online now
Registered User
Subaru Gold Contributor
 
Join Date: Mar 2001
Location: Coffs Harb, Australia.
Posts: 4,971
Significant Technical Input Registered SVX
Re: OEM amplifier question

Good work Steve. I cheated didnít suck the solder out just used a pin drill down through the solder.
I forgot that Phil had it on his site, should have linked you to that first.
You will like the difference it makes the car preform, you wonít turn it off.
__________________
One Arm Bloke.
Tell it like it is!

95 Lsi. Bordeaux Pearl, Aust. RHD.149,000Kls Subaru BBS wheels.
97 Liberty GX Auto sedan. 320,000Kls.
04 Liberty 30R Auto Premium. 92.000kls.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
© 2001-2015 SVX World Network
(208)-906-1122