The Subaru SVX World Network   SVX Network Forums
Live Chat!
SVX or Subaru Links
Old Lockers
Photo Post
How-To Documents
Message Archive
SVX Shop Search
IRC users:
SVXBot

Go Back   The Subaru SVX World Network > SVX Main Forums > Technical Q & A

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2018, 01:31 AM
blue thunder blue thunder is offline
Registered User
 
Join Date: Oct 2003
Location: Bradenton, FL.
Posts: 246
Car not starting questions

My battery and starter both tested good at the auto parts store. I put everything back together and still won't start. No click or anything. I hear a click type noise coming from the back seat area when I turn the key over each time. I've heard that before. I noticed when I have the key in the whole area seems loose. The plastic molding around the steering wheel moves around like it is loose. Don't know if that if abnormal or something is loose. I have replaced the ignition lock cylinder a long time ago. Any thoughts appreciated in advance. I'm ready to have it towed to a local shop to trouble shoot it. This started after it rained for over a week almost every day. Inhibitor or neutral switch? I would not even know where to find it.

Mike
__________________
95 Pearl Blue L
Reply With Quote
  #2  
Old 06-22-2018, 11:15 AM
RisingPhoenix RisingPhoenix is offline
Registered User
 
Join Date: Jan 2018
Location: Idaho
Posts: 31
Talking Re: Car not starting questions

Quote:
Originally Posted by blue thunder View Post
My battery and starter both tested good at the auto parts store. I put everything back together and still won't start. No click or anything. I hear a click type noise coming from the back seat area when I turn the key over each time. I've heard that before. I noticed when I have the key in the whole area seems loose. The plastic molding around the steering wheel moves around like it is loose. Don't know if that if abnormal or something is loose. I have replaced the ignition lock cylinder a long time ago. Any thoughts appreciated in advance. I'm ready to have it towed to a local shop to trouble shoot it. This started after it rained for over a week almost every day. Inhibitor or neutral switch? I would not even know where to find it.

Mike
Do the dash lights come on? The loose steering wheel might be the problem..or the Starter Relay may be bad. Anyway, check the C.T.S. switch, Battery ground that goes under battery (small black wire) engine ground strap (on firewall just under MAP behind Airbox in engine compartment- check for corrosion/bad wires) and the Cam Angle Sensor underneath the Alternator.
Any one of these can cause a 'NO START problem. 🙂
Reply With Quote
  #3  
Old 06-22-2018, 12:13 PM
blue thunder blue thunder is offline
Registered User
 
Join Date: Oct 2003
Location: Bradenton, FL.
Posts: 246
Re: Car not starting questions

Thanks for the in depth reply. Will check into these ASAP.

Mike
__________________
95 Pearl Blue L
Reply With Quote
  #4  
Old 06-22-2018, 01:42 PM
92 SVX 92 SVX is offline
Registered User
 
Join Date: Feb 2010
Location: Jax Florida
Posts: 1,452
Registered SVX
Re: Car not starting questions

The security bolts that go through the ignition switch may have come out causing the looseness, it might even cause a no contact situation though I am unsure of that.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
2001-2015 SVX World Network
(208)-906-1122