The Subaru SVX World Network   SVX Network Forums
Live Chat!
SVX or Subaru Links
Old Lockers
Photo Post
How-To Documents
Message Archive
SVX Shop Search
IRC users:
SVXBot

Go Back   The Subaru SVX World Network > SVX Main Forums > Technical Q & A

Reply
 
Thread Tools Display Modes
  #1  
Old 07-22-2017, 09:54 AM
gwynethh's Avatar
gwynethh gwynethh is offline
Registered User
Subaru Silver Contributor
 
Join Date: Jun 2012
Location: Kittery, ME
Posts: 386
Exhaust /O2 sensor question

After doing a bunch of suspension work we finally got to move the SVX and discovered an exhaust issue.
Last fall we thought one half (P/S) of the muffler was not passing any gas based on under tip moisture and direct feel. This spring neither side did. Car ran with a big gas leak somewhere. We noted hornets clustering around/entering one tip after our test trip of 200 feet or so. So something plugging the system?

We have a used Stebro system complete from the headers back. System is welded and was cut out about 3" back from the cat. We plan to join it with a coupling and clamps.

We have a 1995 OBD1 system. Exhaust has only two O2 sensors forward of the pre-cats. No other sensors or bungs. No sensor in the cat.

So will we get any CEL codes?
Is it hard to unplug the O2 sensor wiring?
__________________
"Peace is the flower of justice."
Reply With Quote
  #2  
Old 07-25-2017, 04:46 PM
gwynethh's Avatar
gwynethh gwynethh is offline
Registered User
Subaru Silver Contributor
 
Join Date: Jun 2012
Location: Kittery, ME
Posts: 386
Re: Exhaust /O2 sensor question

Got an answer. OBD1 only has the two front O2 sensors so OK for that. Guess we will find out how hard it is to unplug the sensors. Leak is at the rear flange of the main cat and if memory serves it is the same failure point as our '92 had about 1999.
__________________
"Peace is the flower of justice."
Reply With Quote
  #3  
Old 07-25-2017, 10:06 PM
Matt007b's Avatar
Matt007b Matt007b is offline
Registered User
 
Join Date: Jun 2009
Location: KSLC
Posts: 54
Re: Exhaust /O2 sensor question

sorry just saw this - but I just BARELY did an o2 sensor change on my 92'.

The connectors are the biggest pain for the job.. they're the same type clip for the ignition coils and they're a bit of a pain to get to..I would slide them off the bracket off the car so you can twist the connector around and at least see what you're looking at. The o2 wire has some slack so you can pull up on them a bit because you don't want to stress the wiring harness. A small screwdriver in the right place and the plug will let go.. Subaru designed those clips to never come off on their own and they do a good job of that...

The car will run semi ok but probably like crap and will run rich..without them plugged in and I'm pretty sure you'll get a check engine light. Mine were bad with no check engine light and when I pulled the plugs the spark plugs were fouled and wet with fuel..

Also this might save you but.. my car had a major hesitation issue and no check engine light. I threw parts at the car and was about to spend hundreds of dollars on a mass air flow sensor/TPS... someone mentioned that you have to reset the ECU to recognize the new o2 sensors I installed. After I did that the hesitation issue is gone...car runs WAAAY better.. little vibration and I'm thinking the injectors need a cleaning but those o2 sensors can really make your car run like total garbage when they're not working right.

If you do unplug them for a good amount of time and replug them in.. I'd make sure you disconnect the battery for a good 10+ minutes (I let it sit overnight) so the ECU will reset and relearn the mixture or else it'll still run like garbage after you plug them in.

Hope that helps :/ good luck on those connectors..
Reply With Quote
  #4  
Old 07-26-2017, 12:41 AM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,284
Re: Exhaust /O2 sensor question

Hey I need 2 new O2 sensors (mine is 95 OBD1) - I have CEL come on when I have been driving for about 10 min.

Does anyone know the P/N for the sensors (do they both have same P/N) - also what costs would they be?.

TIA.
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted.
Reply With Quote
  #5  
Old 07-26-2017, 06:13 AM
Blacky Blacky is offline
51 Club
 
Join Date: Aug 2008
Location: LSM, Quebec
Posts: 2,118
Registered SVX
Re: Exhaust /O2 sensor question

Quote:
Originally Posted by SURTEESS View Post
Hey I need 2 new O2 sensors (mine is 95 OBD1) - I have CEL come on when I have been driving for about 10 min.

Does anyone know the P/N for the sensors (do they both have same P/N) - also what costs would they be?.

TIA.

Bosch #13250 OEM Same part left and right. They are about $45-$50 USD. You might want to confirm that NZ cars use the same O2 sensors as North America.
__________________
1997 Bordeaux, 1992 Claret (parts car) 2011 BMW 535i GT Xdrive, 2006 Nissan X-Trail SE 4WD, 2012 Moto Guzzi Norge GT 8V, 1982 Honda Nighthawk 650

Last edited by Blacky; 07-26-2017 at 06:21 AM.
Reply With Quote
  #6  
Old 07-26-2017, 10:20 PM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,284
Re: Exhaust /O2 sensor question

unsure if NZ uses same as USA - maybe someone else here knows ?.

Shane Hobson, Carl Hoffman, Daniel Parker, Golverine Jackson - what p/n have you used in the past ?.
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted.
Reply With Quote
  #7  
Old 07-27-2017, 06:06 PM
oab_au oab_au is offline
Registered User
Subaru Gold Contributor
 
Join Date: Mar 2001
Location: Coffs Harb, Australia.
Posts: 4,893
Significant Technical Input Registered SVX
Re: Exhaust /O2 sensor question

We only have the front sensors and they are the same as the US.
__________________
One Arm Bloke.
Tell it like it is!

95 Lsi. Bordeaux Pearl, Aust. RHD.148,000Kls Subaru BBS wheels.
97 Liberty GX Auto sedan. 260,000Kls.
04 Liberty 30R Auto Premium. 72.000kls.
Reply With Quote
  #8  
Old 07-27-2017, 10:19 PM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,284
Re: Exhaust /O2 sensor question

Great to hear ....
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted.
Reply With Quote
  #9  
Old 08-07-2017, 08:02 PM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,284
Angry Re: Exhaust /O2 sensor question

So my local Suby agent is dicking me about, I got a CEL come on after about 10 min (temperature is up to normal level).
OK so after doing exhaustive (no pun!!) searches on the web, there are places that have Bosch Oxygen Sensor #13250 for sale (US$50 each) - but the postage is the same price to me here Auckland, New Zealand as the sensor !!!.

I need 2 of these + postage, can someone be a buddy and find out how much it would cost to buy & post to me (weight is approx 0.5lbs for 2 sensors) to this address -

Stephen Surtees
7 Tempo Place
Torbay
Auckland 0630
New Zealand

Will use paypal .......just PM me the details etc - TIA
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted.
Reply With Quote
  #10  
Old 08-08-2017, 11:30 PM
Tireiron Tireiron is offline
Registered User
 
Join Date: Apr 2012
Location: Methuen, MA
Posts: 234
Re: Exhaust /O2 sensor question

What brands do you carry locally? It does not have to be Bosch. I prefer NGK/NTK parts for these cars, but if you can get something locally, they will all work.

Do you have NGK/NTK? The NTK part number is #NTK 24614

Denso is 2343083

Delphi ES10301

acdelco 2131272

walker 25023083

It is the same sensor as a 93-95 Impreza and a 90-94 Legacy (US model years)
Reply With Quote
  #11  
Old 08-09-2017, 10:24 PM
SURTEESS's Avatar
SURTEESS SURTEESS is offline
Registered User
 
Join Date: Oct 2006
Location: Auckland, New Zealand
Posts: 1,284
Re: Exhaust /O2 sensor question

thanks for the info - I have a fellow SVXer from the group preparing to send me them from USA.
__________________
1995 LSI, K&N air filter, SVX side badges (USA type), Rear Deck Blower (JDM type), Side front markers (USA type), Side rear markers (USA type), Middle rear light (USA type), USA OEM Fog Lights fitted into NZ OEM glass (NZ OEM headlights had only reflectors fitted) Full set of yellow Polish bushes includes 15 min mod (90SH fitted), R1 Concepts drilled/slotted/gold finish rotors & Red covered braided brake lines (both from Dayle at Motorsport warehouse), EBC Redstuff brake pads. Full SVX bra (only used for shows). Koni adjustable inserts fitted inside OEM strut body, Zoom lowering springs (2" lower), OEM headlight washers fitted.
Reply With Quote
Reply

Tags
oxygen, sensor, stebro

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
2001-2015 SVX World Network
(208)-906-1122