The Subaru SVX World Network   SVX Network Forums
Live Chat!
SVX or Subaru Links
Old Lockers
Photo Post
How-To Documents
Message Archive
SVX Shop Search
IRC users:
SVXBot

Go Back   The Subaru SVX World Network > Regional SVX Forum & Clubs > US Regional Forums > Northwest Region

Reply
 
Thread Tools Display Modes
  #1  
Old 07-14-2005, 11:46 PM
EddieSVX's Avatar
EddieSVX EddieSVX is offline
shiftin' an automatic
 
Join Date: Mar 2003
Location: Bellevue, WA
Posts: 297
Send a message via AIM to EddieSVX
My CEL flashed once while driving a few nights ago but didn't come back

My CEL flashed at my while crusing during decceleration a few nights ago. It quickly went away and never came back. I decided to check for engine codes today and it displays a code 28 (Knock sensor 2, LH), no other codes.

Could the knock sensor be going bad, did something random trigger the knock sensor, or could there be any other issues? Is the CEL supposed to stay on if it's a bad sensor? My engine wasn't running rough and did not feel powerless. It also idled normally.

I may be buying the pair of knock sensors from one of the guys selling them in the for sale forum, but before I do, should I just clear the code and see what happens in the next few days?
__________________
Eddie
'92 SVX LS-L (For Sale! Info and link to pics... ) #9536 blt. 4/92 (late boomer '92)
'01 Audi S4 (2.7L Twin Turbo - 6MT)
Reply With Quote
  #2  
Old 07-15-2005, 12:15 AM
ensteele's Avatar
ensteele ensteele is offline
Betcha can't buy just one!
Alcyone Gold Contributor
 
Join Date: Jan 2002
Location: Burlington, WA
Posts: 19,521
Send a message via ICQ to ensteele Send a message via Yahoo to ensteele Send a message via Skype™ to ensteele
Registered SVX Classic SVX
I have had that happen too. It has never come back on, so I have not worried about it. If it comes on again, you might want to check it, but if it doesn't, I would not worry about it now. jmho
__________________
.
Earl .... ... .... ><SVX(*>

Subaru Ambassador
http://www.subaru-svx.net/photopost/showgallery.php?cat=500&ppuser=469 ~45K (06/91) #2430
1992 Dark Teal LS-L ~184K (05/91) #0739
1992 Claret LS-L ~196K (05/91) #0831
1992 Pearl LS-L ~103K (06/91) #1680
1992 Pearl LS-L ~151K (06/91) #2229
1992 Dark Teal LS ~150K (07/91) #3098 (parts car)
1992 White LS-L ~139K (08/92) #6913
1993 25th AE ~98K (02/93) #164
1993 25th AE ~58K (02/93) #176
1993 25th AE ~107K (02/93) #215
1993 25th AE ~162K (02/93) #223
1994 Laguna Blue Pearl LSi ~124K (1/94) #2408
1994 Laguna Blue Pearl LSi ~144K (10/93) #1484
1994 Laguna Blue Pearl LSi ~68K (10/93) #1525
1994 Barcelona Red LSi ~46K (02/94) #2624
1994 Pearl LSi ~41K (12/93) #1961
1995 Bordeaux Pearl LSi ~70K (02/95) #855
1996 Polo Green LSi ~95K (03/96) #872
1997 Bordeaux Pearl LSi ~55K (08/96) #097
2003 Brilliant Red LS1 Convertible ~29K (04/03) #8951
1999 Magnetic Red LS1 Coupe ~33K (04/99) #6420

My Email | Old Locker | New Locker | Picture of 15 of the 19
Reply With Quote
  #3  
Old 07-15-2005, 10:36 AM
Earthworm's Avatar
Earthworm Earthworm is offline
Meow!
 
Join Date: Mar 2002
Location: Winnipeg, Manitoba
Posts: 11,961
Send a message via ICQ to Earthworm Send a message via AIM to Earthworm Send a message via MSN to Earthworm Send a message via Yahoo to Earthworm Send a message via Skype™ to Earthworm
It's probably the sensor going bad. My old sensors were both cracked.
Reply With Quote
  #4  
Old 07-15-2005, 10:44 AM
EddieSVX's Avatar
EddieSVX EddieSVX is offline
shiftin' an automatic
 
Join Date: Mar 2003
Location: Bellevue, WA
Posts: 297
Send a message via AIM to EddieSVX
I'll visually inspect both this weekend. I would think if either sensor had gone bad, the CEL would remain on or flash at me more often.

Thanks to both of you for the info. I'm going to hold off on buying the replacement sensors until I confirm they do need replacing (test and visually inspect them).
__________________
Eddie
'92 SVX LS-L (For Sale! Info and link to pics... ) #9536 blt. 4/92 (late boomer '92)
'01 Audi S4 (2.7L Twin Turbo - 6MT)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
2001-2015 SVX World Network
(208)-906-1122